当前位置:首页 > 问答

同花顺组合条件选股

我来帮TA回答

如何将同花顺中的分析指标改为条件选股公式?

AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);

AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);

AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);

B1万元:=DVOL*DCLOSE/100;

净流入万元:=(AAA2-AAA3-0.5*AAA4);

PM:=MA(净流入万元,1);

PMA:=PM/REF(PM,1)>1;

PMB:=REF(PMA,1)<1 AND PMA;

密码:=(EMA(MA(B1万元,2),2))/100000;

二日比:=密码/REF(密码,1);

选股:=PMB AND 密码>REF(密码,1) AND 二日比>1;

均价线:=AMOUNT/V/100;

均价线2:=EMA(均价线,3);

XG:C>均价线2 AND 均价线2<REF(均价线2,1) AND REF(均价线2,1)<REF(均价线2,2)

AND REF(均价线2,2)<REF(均价线2,3) AND 选股;


注意未来函数

同花顺如何自定选股设置

不用那么麻烦的.同花顺软件按95就行了.

同花顺多条件选股- 公式写法

601318.

同花顺如何添加按条件选股功能?

您可以使用问财免费选股功能,问财选股在手机炒股软件首页九宫格的第二屏中有问财的免费选股功能,进入应用可以输入您的选股条件即可选出您要的股票。

金融终端如何使用选股器?

您好,您可打开金融终端,点击“菜单”-“选股器”,选择任一种选股方式后选择或设置指标条件后点击“加入条件”再点击“执行选股”或“选股入板块”。详细操作方法可查询帮助说明文件中的“功能-选股器”。

通信达选股器怎么用?

给你举2个例子,你会用这两个了,其它的就会触类旁通。
例子1:依次点击功能/选股器/条件选股/,再最上面的下拉条中找到/出水芙蓉,点击/加入条件,选日线,勾选历史阶段选股,将前后日期都设定为你的选股当日,点击/执行选股即可。就用/出水芙蓉挺好。
例子2:自编的选股公式如何使用
我的操作方式是
创建公式:在公式管理器中新建,复制粘贴,创建公式
选股:选股器-综合选股-用户条件-指标选股-其他类型-找到刚创建的选股公式
以下是两个网上找的选股公式
公式一:
{底背离}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
底背离:B1>0 OR B2>0 OR B3>0;
公式二:
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:EMA(DIFF,9),COLORFFFF00;
MACD:(DIFF-DEA)*2;
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;
STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLORGREEN;
STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF00FF;
STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;
多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,DEA,' 低位金叉'),COLORFF00FF;
{STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;
DRAWICON(低位金叉,0.3,1)};
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.2,2,0),COLORFF00FF;
DRAWTEXT(二次金叉,DEA*1.06,'二次金叉'),COLORRED;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
{STICKLINE(底背离,0.5,0.8,2,0),COLORRED};
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK3;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK3;