当前位置:首页 > 问答

通达信自动标记

我来帮TA回答

通达信 怎样自动标志高低点价格

这个是需要用到主图公式的,自动出来的只有页面显示的K线一个最高和一个最低。
下面的公式自己去创建一个主图用的就可以显示波段的高低点价格了。
A1:=REF(H,7)=HHV(H,2*7+1);
B1:=FILTER(A1,7);
C1:=BACKSET(B1,7+1);
D1:FILTER(C1,7),NODRAW;{高点}
A2:=REF(L,7)=LLV(L,2*7+1);
B2:=FILTER(A2,7);
C2:=BACKSET(B2,7+1);
D2:FILTER(C2,7),NODRAW;{低点}
E1:=(REF(LLV(L,2*7),1)+REF(HHV(H,2*7),1))/2;
E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1),LINICK0;{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1),LINICK0;{过滤后高点}
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:R1>REF(R1,1),NODRAW; {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2);
U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2);
U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2);
S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2);
S4:=R4>REF(R4,1); {前四高}
压力1:=DRAWLINE(S2,H,S1,H,1),COLORMAGENTA,LINICK1;
压力2:=DRAWLINE(S3,H,S2,H,1),COLORFF8000;
压力3:=DRAWLINE(S4,H,S3,H,1),COLOR0000FF;
支撑1:=DRAWLINE(U2,L,U1,L,1),COLOR8FBC8F,LINICK1;
支撑2:=DRAWLINE(U3,L,U2,L,1),COLOR99CC32;
支撑3:=DRAWLINE(U4,L,U3,L,1),COLOR00FF7F;
{DRAWICON(S2,H*1.01,10);
DRAWICON(S3,H*1.01,10);}
DRAWNUMBER(S2,H*1.024,H),COLORWHITE;
DRAWNUMBER(S1,H*1.024,H),COLORWHITE;
DRAWNUMBER(S3,H*1.024,H),COLORWHITE;
DRAWNUMBER(S4,H*1.024,H),COLORWHITE;
DRAWNUMBER(U1,L*0.99,L),COLORGRAY;
DRAWNUMBER(U2,L*0.99,L),COLORGRAY;
DRAWNUMBER(U3,L*0.99,L),COLORGRAY;
DRAWICON(U1,L*0.99,11);
高一:DRAWLINE(S1,H,REF(S1,1),REF(H,1),1)COLORRED,DOTLINE;
高二:DRAWLINE(S2,H,REF(S2,1),REF(H,1),1)COLORMAGENTA,DOTLINE;
高三:=DRAWLINE(S3,H,REF(S3,1),REF(H,1),1)COLORLIRED,DOTLINE;
低一:DRAWLINE(U1,L,REF(U1,1),REF(L,1),1)COLORGREEN,DOTLINE;
低二:DRAWLINE(U2,L,REF(U2,1),REF(L,1),1)COLORLIBLUE,DOTLINE;
低三:=DRAWLINE(U3,L,REF(U3,1),REF(L,1),1)COLORLICYAN,DOTLINE;

在通达信上如何使公式选出的过去某一时段的股票自动标记出形态具体位置?

这个简单呀,使用drawicon函数就可以做到了呀,可以在出信号的位置标出你喜欢的符号就可以了。
如还不明白,请把公式发上来,我帮你改。

通达信主图如何在在自动画线上面标注文字

这要看你自动画线的条件了
如果是有条件的自动画线就按照条件来呗,例如背离下图的背离画线,这需要源码才能在条件成立时标注文字,或者划线时有数值建立一个新指标引用这个指标根据数值的变化标注文字


如果你要简单之字转向划线那就简单了,
直接按照下面的代码写就可以了
A:ZIG(3,5);
LL:=A>REF(A,1) AND REF(A,1)<REF(A,2);
HH:=AREF(A,2);
DRAWTEXT(LL,L,'底')COLORRED;
DRAWTEXT(HH,H,'顶')COLORGREEN;
主要之字转向是未来函数

请问如何把所有的股票K线上自动标记符号

只知道把均线可以设置成,日K线的只能在你选的那些天数增加上个股备忘(我用的是同花顺)。

通达信如何导出 文字标记

文字标记是指标提示,可以将整个指标导出。
方法是:功能--专家系统--公式管理器--导出公式--找到公式打钩--导出。

新版的通达信软件怎么修改标记文字

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
忽略以上公式。 右键点击文字部分,会弹出选项,修改删除由你选择就可以了。